Forum

Counter Rate not calculating(?)  

  RSS

(@natebrews)
Active Member
Joined: 5 months ago
Posts: 12
January 23, 2019 4:10 am  

As I'm getting into playing with the system a bit, I'm gradually trying out features.  Tonight I tried using a counter, but I'm getting no rate information.  

The setup:  NodeMCU over TCP/IP with an old CPU fan connected to VIN(4.7V) using the RPM sense output going to GPIO[0].   I checked the amplitude of the sense on my scope and it is <3.3V and seems to be registering OK since the count is going up at about 60/second.  The rate information is not changing however, (stuck at zero).  I reread the manual section on counters, and tried adding some math functions for the rate (even just *1) to see if it would change it, to no avail. Adding a linear offset does show up in the displayed rate.

Any advice would be appreciated.  I'm sure I'm missing something simple, but I can't seem to figure out what. 


Quote
(@pbruno3)
Estimable Member Admin
Joined: 2 years ago
Posts: 239
January 28, 2019 6:39 pm  

Discussed live... GPIO 0 has issues... will be fixed!


ReplyQuote
Share: