Forum

HELP! Not able to u...
 

[Solved] HELP! Not able to update firmware or set-up network after installing Adafruit WiFi WINC1500 shield  

  RSS

(@piggles22)
Active Member
Joined: 12 months ago
Posts: 13
September 18, 2018 5:46 pm  

I recently purchased and installed the Adafruit WINC1500 WiFi shield and added it to my MEGA2560 interface (which was working fine with BruC in Serial mode). I followed the online steps (from the Adafruit website) to update the firmware (using the Arduino IDE) on the WiFi shield and updated to WiFi shield firmware 19.5.4. It was initially work very well over WiFi but then something happened while testing the interface and WiFi shield using the Arduino IDE scripts....now it seems I've completely lost comms with the interface and the WiFi shield.

Seems that no matter what I try, I'm not able to re-establish communication with the MEGA2560 interface to update firmware or set-up a WiFi network again.

When I run the interface set-up tool for BruC and choose firmware installation (option 1) I get as far as selecting the correct port, then when asked to select which firmware option to upload, there is no list of options to choose from. 

When I run network set-up (option 2), I again get as far as selecting the comm port but the Termite window never opens.

 Now when I try testing the connection using the firmware update from the Arduino IDE, I get a connection error: "programmer not responding". 

I'm stuck and don't know how to resolve this. What do I do from here?

Greg


Quote
(@piggles22)
Active Member
Joined: 12 months ago
Posts: 13
September 19, 2018 8:22 pm  

I've copied and pasted the email chain on the resolution to this problem. I thought it might be helpful to anyone else running BC on virtual Windows machine running on a MAC computer:

Persistency has paid off! I finally got it to configure using the interface set-up tool, as well as set up the WiFi connection. I'm not sure but it may have been a corrupt interface set-up file or more likely the way I was accessing the file from a shared folder (shared folder on a MAC desktop with a short-cut link pasted on a Windows virtual desktop running on VMWare Fusion). I downloaded a new copy of the interface set-up tool and ran it directly from the Windows desktop. The Windows software did try to block it since it didn't recognize the software but I was able to override that. I now have it configured to blink the onboard LED on the MEGA every 5 seconds using the WiFi interface configured in BruC. I think I will leave it running like that for the next 24 hours just to make sure there are no hiccups.

[name redacted]

On 9/18/18 3:34 PM, BruControl Info wrote:

I’m a bit lost. The IDE can communicate with the MEGA but the firmware installation tool cannot?

They both upload code using the same mechanism. Can you screenshot what errors are generated when you try to upload the MEGA FW using the tool?  

Best regards,

 

[name redacted]

On Sep 18, 2018, at 5:45 PM, [name redacted] wrote:

[name redacted],

The MEGA does show up as COM port 3 in the Device Manager. It also shows up as a selectable port in the IDE as well as in BruControl. I'm not sure what actually happened while testing the interface; I was simply uploading and running of few of the example files from the WiFi101 library to test the WiFi card communications (in accordance with the Adafruit website tutorials) which seemed to work just fine (and still do for the most part). When I quit the testing from the IDE, I started BruC to set up the interface. BruC will still establish a serial interface but it disconnects and reconnects every 5 seconds or so. I can also select the COM port and set-up the WiFi interface but it never connects.

I then tried to re-run the interface set-up tool for BruC and got the results I described in my previous email. The example files run from the Arduino IDE still connect via WiFi so it seems to be transmitting and receiving.

Not sure what a new bootloader will do but if you think it might fix the problem I'm willing to give it a try. If it is a last ditch effort, I would like to try to exhaust other possible fixes.

[name redacted]

On 9/18/18 12:14 PM, BruControl Info wrote:

Hi [name redacted],

It sounds like the MEGA is not responding and presenting a COM port to communicate through. When it is plugged in, does your Windows’ Device Manager show it in the list of COM ports? Does it show up as a selectable COM port in the IDE? Can you explain “something happened while testing the interface and WiFi shield using the Arduino IDE scripts” in more detail?

There is a tricky way to upload a new bootloader, but it is possible that will not solve the problem, as the USB chip onboard is what performs the communications interface over USB. In that case, given the inexpensive nature of the MEGA, I would recommend you purchase a replacement and swap them out.

 

Regards,

[name redacted]

 

This post was modified 11 months ago by pbruno3

ReplyQuote
Share: